This document is deprecated. For the latest version, please see http://packages.python.org/wille/

Running Wille on Jython

Wille mainly works well on Jython. Especially if you wish to create operating-system independent, standalone Wille installations, use of Jython is an appealing option.

Note however that some Python libraries are not available for Wille: components requiring these libraries may not work on Jython. Also note that Wille works notably slower on Jython. For computationally demanding tasks, we do not recommend using Jython.

Setting up Wille on Jython

When setting up Wille to run on Jython, follow setup documentation on GettingStarted with the following differences:
  • At least Jython 2.5.1 is required [1]
  • You need to set up JYTHONPATH instead of PYTHONPATH

Notes

  1. For an unknown reason, running Wille on Jython 2.5.0 in Windows may crash your whole system. We have not been able to reproduce the problem on any system running Jython 2.5.1 or later.
Print version |  PDF  | History: r6 < r5 < r4 < r3 | 
Topic revision: r6 - 12 Mar 2013 - 14:43:45 - JaakkoSalonen
 

TUTWiki

Copyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TUTWiki? Send feedback